First Bike

Please post your bike pics here

Moderators: Volker_P, tidd650

Maelos
Posts: 13
Joined: Tue Sep 17, 2013 10:40 pm

First Bike

Postby Maelos » Sun Sep 22, 2013 8:45 am

I already posted in the support forums about my brakes, I'd better put an introductory post here before I get too far on the bike.

I recently picked up an '81 CB650C. Going in I knew it needed a little love, but the price was right and I really liked the way the bike felt underneath me. I have little to no mechanical knowledge, but like most people like me, I have a buddy that does. :lol:

You can't tell from this photo, but the exhaust needs replaced, the tank has a slight dent near where it mounts that some red cancer has gotten into as well as misc. nicks in the paint. I plan on sanding/attempting to bondo out the dent and repainting in a flat black theme with some red accents to try and tie my seat in a little better over-all.

I'll do my best to keep this thread updated as I go, but with little time and funds, it will be slow going. Enjoy!

For those of you with a Google+ account, here is a link to an album where I am putting photos.

Image

User avatar
Folsoml
Posts: 1630
Joined: Sat Apr 07, 2012 9:02 pm
Location: North Florida

Re: First Bike

Postby Folsoml » Sun Sep 22, 2013 12:20 pm

Looks like a fun project! Did that seat come off a Goldwing?
Have a problem with your CB650? Have a technical question? Click here!


My Current Bikes: 2005 HD FLHTCUI Electra Glide Ultra Classic, 2007 Yamaha Vino,

Maelos
Posts: 13
Joined: Tue Sep 17, 2013 10:40 pm

Re: First Bike

Postby Maelos » Mon Sep 23, 2013 6:39 am

No idea where the seat came from, PO didn't know either. It is comfortable, and the wife will appreciate it as well, once I get it into ride-able condition.

Maelos
Posts: 13
Joined: Tue Sep 17, 2013 10:40 pm

Re: First Bike

Postby Maelos » Thu Sep 26, 2013 7:21 pm

Update time!

Tank has been cleaned, front left caliper is braking as it should be.

Now to tackle the fact that my brake light doesn't illuminate at all when the front or rear brakes are used and my right side turn signals don't blink, but left side does.

*Click on images for full size images*

Tail light had one bulb broken, replaced it with no change. Cleaned up the plug by the rear fender that looks like it leads to all the lights. One of contacts was corroded and charred.
Image

I then looked at the connector that plugs into the main 30amp fuse. It didn't look too bad, but I cleaned it anyway. I did notice something odd, however. Something tells me this isn't right.
Image

Charging the battery or cleaning the contacts fixed my blinker AND brake light problem! Just need to replace the 30amp main and get the carbs back from being cleaned. Might be able to ride yet this season!

entropy
Posts: 21
Joined: Mon Jul 08, 2013 6:46 pm
Location: Blacksburg, VA

Re: First Bike

Postby entropy » Thu Sep 26, 2013 8:53 pm

Great to see the motorcycle coming together with work. :)

cb650
Posts: 2945
Joined: Fri Mar 03, 2006 7:20 am
Location: Denver CO USA
Contact:

Re: First Bike

Postby cb650 » Thu Sep 26, 2013 11:36 pm

Not the right "fuse". Seat looks like a aspencade aftermarket but never seen one in red.
Did you clean the tank out?!?!?!?!

User avatar
Folsoml
Posts: 1630
Joined: Sat Apr 07, 2012 9:02 pm
Location: North Florida

Re: First Bike

Postby Folsoml » Fri Sep 27, 2013 8:15 am

I don't even know what that "fuse" is! :roll: Most people just replace it with a paperclip!
Have a problem with your CB650? Have a technical question? Click here!


My Current Bikes: 2005 HD FLHTCUI Electra Glide Ultra Classic, 2007 Yamaha Vino,


Return to “Show it off”

Who is online

Users browsing this forum: No registered users and 8 guests